Kontrollkästchen in Excel 2010 einfügen

Excel bietet sehr nützliche Formularsteuerelemente, mit denen Benutzer ein Steuerelement erstellen und mehrere Dinge gleichzeitig ausführen können. Sie können Schaltflächen, Kontrollkästchen, Beschriftungen, Kombinationsfelder, Bildlauflisten usw. hinzufügen. Die tatsächliche Verwendung von Formularsteuerelementen kann erreicht werden, wenn Sie mit einem kolossalen Datenblatt arbeiten, und Sie müssen mehrere Funktionen und Aktionen in der gewünschten Reihenfolge aufrufen. Diese Steuerungen helfen Ihnen auch, wenn die Datenzellen miteinander verbunden werden. In diesem Beitrag werden wir verwenden Kontrollkästchen Formularsteuerung in einem Szenario, in dem mehr als zwei Bereiche miteinander in Beziehung stehen.

Starten Sie Excel 2010 und erstellen Sie ein Datenblatt, auf dem Sie Kontrollkästchen mit verschiedenen Aktionen verknüpfen möchten. Zum Beispiel haben wir eine Anwesenheitsliste von Studenten erstellt, die Felder enthält, Name, und Teilnahme. Wir haben hat auch eine weitere Tabelle in unser Datenblatt aufgenommen, die Felder enthält Gesamt, Gegenwart, und Abwesend.



Anwesenheitsliste

Um anzufangen, müssen wir machen Entwickler Registerkarte im Excel-Fenster sichtbar. Falls Sie nicht finden Entwickler Registerkarte, gehen Sie zu Datei Menü, klicken Optionen und im linken Bereich klicken Band anpassen, aus dem rechten Bereich aktivieren Entwickler Kontrollkästchen. Klicken OK zu um zu sehen Entwickler Registerkarte auf dem Band.

Registerkarte „Entwickler“.

Jetzt werden wir Checkboxen in das Datenblatt einfügen, um Tabelleneinträge mit einem einzigen Klick zu füllen. Navigieren Sie zu Entwickler Registerkarte, von Einfügung Optionen, klicken Sie auf das Kontrollkästchen Bild vorhanden unter Formularsteuerelemente, wie im Screenshot unten gezeigt.

Entwickler

Beim Klicken wird ein Pluszeichen-Zeiger angezeigt. Klicken Sie auf die Stelle, an der Sie das Kontrollkästchen hinzufügen möchten.

Kontrollkästchen

Wählen Sie den Text aus und entfernen Sie ihn, und klicken Sie dann mit der rechten Maustaste darauf, klicken Sie Formatsteuerung.

Rechtsklick

Das Steuerung Registerkarte von Formatsteuerung Dialog öffnet sich. Von Zellverbindung, Wählen Sie die Stelle im Datenblatt aus, an der Sie den Aktivierungs-/Deaktivierungsstatus des Kontrollkästchens anzeigen möchten, der TRUE bzw. FALSE sein wird. Klicken In Ordnung weitermachen.

Kontrollkästchenoptionen

Jetzt verschieben wir das Kontrollkästchen an das Ende der Teilnahme Zelle, werden Sie feststellen, dass sich die Zelle auf sie bezieht H2 location, wodurch die Werte TRUE/FALSE geändert werden.

falsch 1

Beim Aktivieren des Kontrollkästchens ändert sich der Wert in der H2-Position automatisch. Wir schreiben die Formel hinein Anwesenheitssäule vor Ort C2 , und das wird den Wert einchecken H2 Lage,

=WENN(H2=WAHR, vorhanden, nicht vorhanden)

Der erste Parameter der Formel H2=WAHR, überprüft den Wert in H2, wenn er WAHR ist, Schlüsselwort Geschenk wird in der Zelle angezeigt, und wenn es falsch ist, dann Abwesend erscheint in der Zelle.

Anwesenheit vorhanden 1

Gehen Sie nun genauso vor, um Kontrollkästchen mit allen Zellen einzufügen Teilnahme Feld. Wie Sie im Screenshot unten sehen können, haben wir Kontrollkästchen mit den Zellen erstellt, und wo das Kontrollkästchen aktiviert ist, ändert sich der entsprechende Wert in der H2-Spalte auf TRUE, schließlich durch die Formelauswertung Geschenk erscheint in der entsprechenden Zelle im Anwesenheitsfeld.

komplette Tabelle

Jetzt fangen wir an, die nächste Tabelle zu füllen, hier sind wir eingetreten 10 insgesamt Reihe (da wir 10 Schüler haben) .

nächste Tabelle 1

Wir zählen das Vorkommen des Schlüsselworts Geschenk in der Tabelle Teilnahme Säule . Also werden wir die Formel schreiben als;

=ZÄHLENWENN(C2:C11, Präsens)

Das Ergebnis ist 9, da nur ein Schüler abwesend ist.

Geschenkstollen `1

Um nun zu überprüfen, wie viele Schüler abwesend sind, subtrahieren wir einfach die Anzahl der anwesenden Schüler von der Gesamtzahl der Schüler. Die Formel geht so

=($B-$B)

Es subtrahiert einfach den Wert bei B15 (Studenten anwesend) vom Wert bei B14 (Gesamt) und liefert das gewünschte Ergebnis.

Anwesenheit abwesend

Sie werden auch feststellen, dass beim Aktivieren/Deaktivieren des Kontrollkästchens automatisch alle zugehörigen Informationen aktualisiert werden.

Komplett

Sie können sich auch zuvor überprüfte Leitfäden ansehenVerwenden von Makros über Schaltflächen&Verwenden des Kamerawerkzeugs in Excel 2010.

Holen Sie sich tägliche Tipps in Ihren Posteingang Newsletter abonnieren 35.000+ andere Leser
Beste USB-WLAN-Adapter für Linux (Rezension) im Jahr 2022 Vorherige Artikel

Beste USB-WLAN-Adapter für Linux (Rezension) im Jahr 2022

So verschieben Sie den Desktop-Ordner aus OneDrive unter Windows 10 Weiterlesen

So verschieben Sie den Desktop-Ordner aus OneDrive unter Windows 10